Porsche — Underwater road
3d award

Замедление производительности при работе в окне развертки "unwrap

Online|Offline Gast7302 0.0 7.5 28 сентября 2012 в 09:15 #0

Аватар Gast7302
Когда я начинаю менять размер окна развертки "unwrap UVW", замедляется производительность системы.
Второе, когда я начинаю передвигать элементы UVW развертки по полю - не важно какие (хоть даже один полигон) - тоже, замедляется вся система.
К примеру: вот я взял элемент UVW, быстро мышкой подергал влево-враво, и через некоторое время, компютер начинает медлено перемещать этот элемент UVW - сначала влево, потом, вправо... это так медлено происходит, что работать просто невозможно.
Я даже не знаю в чем, собственно, дело.

Сам компьютер - не слабенький: 4 гб, Виндовс 7 Максимальная 64 бит , видеокарта 1 гб ATI.
Раньше стоял Виндовс 7 Расширенная 32 бит, так все было нормально! :''(
Но правда, тогда Макс часто вылетал, из-за чего запароливались все проэкты, и поэтому мне пришлось HDD забить нулями и записать все по новой... поставив Виндовс 7 Максимальная 64 бит.

После установки новой системы, установил все драйверы: сначала для материнки, а потом и на все остальное. Потом первым делом, я поставил 3д макс (макс скачал с оф. сайта). Первое время, я в него не заходил и не работал в нем. Плюс еще я на него поставил пакет обновления 2. Далее, установил одну игру "SCP - Containment Breach". Когда начинается игра, предлагается выбрать видео-адаптер, и его там, почему-то, оказалось два! меня это немнго насторожило, так как у меня имеется одна видеокарта ( но может, это просто в списке еще и видео ядро моей материнки...). После чего, я обнаружил замедление производительности в окне развертки "unwrap UVW".

Причем медлит так, как браузер Опера в Яндекс картах (может это у меня так, не знаю, а у вас нет?). допустим, хочу передвинуть карту, а она передвигается очень медлено. Оно не тормозит, а вот именно что медлит!

Вот на другом компе стоит такой же 3д макс как и на моём - но в него не установлен пакет обновления 2 - и ничего не медлит.

Может, такое замедление от драйверов ATI... , или может центр обновления Виндовс что-то установил лишнее, как говориться. Или вообще, все из-за пакета оновления 2.

Кто-нибуть уже сталкивался с такой проблемой и как её решить? (можно будет попробовать просто переустановить макс)

Online|Offline Змей Горыныч 167.1 1511.5 28 сентября 2012 в 10:22 #0

Аватар Змей ГорынычПобед в битвах:9Побед в битвах:9
Унврап вообще вещь тормознутая, не только у тебя так тормозит

Online|Offline BеаrTаnk 11.0 63.8 28 сентября 2012 в 10:47 #0

Аватар BеаrTаnkПобед в битвах:1Побед в битвах:1
В настройках видеокарты стоит ЦП или видюха? Просто цп рендерит медленнее, возможно это и тормозит еще развертку.

Online|Offline Gast7302 0.0 7.5 28 сентября 2012 в 15:19 #0

Аватар Gast7302
В настройках видеокарты стоит ЦП или видюха? Просто цп рендерит медленнее, возможно это и тормозит еще развертку.
Вся загвоздка в том, что я не знаю, как это проверить.

Я зашел в Customize - Preferences - Viewport - Displat Driver - там стоит моя видеокарта и драйвер Nitrous

Или надо куда-то еще лезть?

Online|Offline homerender 101.1 1384.3 28 сентября 2012 в 22:39 #0

Аватар homerenderПобед в битвах:3Побед в битвах:3
В настройках видеокарты стоит ЦП или видюха?

Че?) Это как?)

Online|Offline BеаrTаnk 11.0 63.8 29 сентября 2012 в 11:02 #0

Аватар BеаrTаnkПобед в битвах:1Побед в битвах:1

Online|Offline Gast7302 0.0 7.5 29 сентября 2012 в 23:35 #0

Аватар Gast7302
А, точно, не догодался, что это в установленном драйвере видеокарты) .

Вообщем, в своем "Catalyst Control Center" - ничего подобного ненашел, собственно у меня не nVidia a ATI карта. Там только: настройка цвета, настройка дисплея, отображение, качество, да разгон видеокарты (только крутить частоты видеоадаптера).

Online|Offline homerender 101.1 1384.3 30 сентября 2012 в 16:51 #0

Аватар homerenderПобед в битвах:3Побед в битвах:3
А каким боком PhysiX относится к UVW Unwrap, да и вообще к вьюпорту? Он нужен разве что в MassFX. Это физический движок, который здесь явно не причем.

Online|Offline Gast7302 0.0 7.5 1 октября 2012 в 21:33 #0

Аватар Gast7302
Вот У меня такая проблемя, когда я перетаскиваю огромное количество полигонов по полю Unwrap Map- Ничего не тормозит, а замедляется система и мышь. Хотя, мышь, по идее, не должна замедляться! Тут походу какая-то технология стоит, Помнится такая была в игре "Pariah "
- Представте, Вот имеется слабая ВидеоКарта, которая тормозит во всех играх (все идет рывками). И только в игре "Pariah" - для этой тормознутой видеокарты - специально активизируется технология, для сглаживания Тормозов - и картинка идет плавно и медлено, как в фильме Матрица. - типо такое замедление времени наступает.
Играть было конечно кульно ;D.
Так вот это и здесь, в 3d max- но зачем надо замедлять перемещение курсора мыши, при огромном количестве полигонов - я не понимаю.

На первом компе
Смотрите, я создал сферу - нагнал на неё 1 000 000 полигонов - и положил на неё Unwrap Map - Начинаю перемещать эту сетку по UVW'шному полю - Заметьте, не тормозит! а просто медленно перемещается! В том числе и мышь.- Вот уже включается "технология" какая-то
Я уже, как 3 секнды назад отцепил клавишу мыши, так она досихпор простаскивает по траэктории эти Полигоны, И причем, яэти три секунды - ничего делать не могу. остается ждать пока мышка плавно пройдет ту траэкторию и отпустит эту Сетку/Полигоны.

А, вот теперь,что происходит на другом компе, на котором не стоит ServicePack 2 для 3dMax .
Тоже, создал сферу - дал ей 1 000 000 полигонов - поставилна неё Unwrap Map - и начинаю перемещать эту сетку по полю. Да, вот тут начинаются тормоза - все перемещается "Рывками" - нет той "замедленности"/сглаживания тормозов, как в первом случае. Причем,с мышкой - все нормально . Я её могу в любой момент отпустить, и перемещение "Сетки"/полигонов - прервется.


Я думаю, что все это из-за ServicePack 2 для 3dMax.

Online|Offline homerender 101.1 1384.3 2 октября 2012 в 10:58 #0

Аватар homerenderПобед в битвах:3Побед в битвах:3
Странные у тебя оба компьютера

Online|Offline Gast7302 0.0 7.5 4 октября 2012 в 12:14 #0

Аватар Gast7302
Вообщем, переустановил 3д макс на первом компьютере - проблема не решилась.

Похоже, что я этого просто не замечал, так как когда раньше работал с High poly моделями - то просто не обращал внимание на тормоза во время работы в Unwrap UVW. А щас вдруг чего-то обратил

Online|Offline Gast7302 0.0 7.5 23 декабря 2012 в 19:55 #2

Аватар Gast7302
Наконец-то мне удалось решить эту проблему. Теперь у меня во время перетаскивании UVW элементов ничего не тормозит и не глючит, как это было ранее.
В окне Edit UVW's зайти в меню настроек: Options - Preferences...

В появившемя окне Unwrap Options - найти область Display Preferences , и на против Constant Update In Viewport снять галочку.


Сама эта функция позволяет динамически изменять положение текстуры на объекте в реальном времени, в то время когда мы перетаскиваем UVW элемент. - Именно из-за этого и начинались тормоза/глюки.

Все-таки конец света не такой уж и плохой!

Online|Offline Virat 1.0 54.0 23 декабря 2012 в 22:24 #0

Аватар Virat
Gast7302, спаситель!!!!!!)))

Online|Offline Gast7302 0.0 7.5 28 декабря 2012 в 12:11 #0

Аватар Gast7302
пасиб)))
Что бы оставить сообщение вам необходимо войти или зарегистрироваться!

Форумещё

Блогиещё

Популярные урокиещё

Реклама

3dmir.ru - Вся компьютерная графика
      www.megastock.ru